首頁 / System / Linux / ubuntu / Insecure dependency in require while running setuid…

Insecure dependency in require while running setuid…

[Wed Mar 12 10:50:29 2008] [error] [client 60.250.224.208] Insecure dependency in require while running setuid at ….awstats.pl ….
[Wed Mar 12 10:50:29 2008] [error] [client 60.250.224.208] Premature end of script headers: awstats.pl, referer: ….

這是最近在升級Ubuntu到7.10之後,perl又不能正常地讓awstats運作了的錯誤紀錄,搞不懂perl有做什麼改進,查到Google的http://typo3.org/documentation/document-library/extension-manuals/ics_awstats/0.1.4/view/1/5/

在程式第一行改用 /usr/bin/perl -U,測試後果真沒錯!

Print Friendly, PDF & Email
馬上成為工作達人的Fans

About ㄚ琪

工作達人Fun Taiwan的創辦者及總編,可以在這裡更認識他。

發表迴響

你的電子郵件位址並不會被公開。 Required fields are marked *

*

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料

Scroll To Top