Centos 5 安裝 QTerm

參考它的安裝說明操作
checking for X… configure: error: Can’t find X includes. Please check your installation and add the correct paths!
在應用程式->新增/移除軟體->程式開發->X軟體開發勾選就可以解決!

checking for Qt… configure: error: Qt (>= Qt 3.1 (20021021)) (headers and libraries) not found. Please check your installation!

我在應用程式->新增/移除軟體->搜尋qt相關檔案後安裝了qt4-devel及qt-devel等套件,還是錯誤

後來在http://unix-cd.com/vc/www/15/2007-10/9138.html,發現原來./configure後面要加qt的相關參數,我的/usr/lib下有qt4及qt-3.3所以我下這樣的命令:
./configure –with-qt-dir=/usr/lib/qt4/ –with-qt-includes=/usr/lib/qt4/include/ –with-qt-libraries=/usr/lib/qt4/lib/
還是一樣的錯誤
我只好改成
./configure –with-qt-dir=/usr/lib/qt-3.3/ –with-qt-includes=/usr/lib/qt-3.3/include/ –with-qt-libraries=/usr/lib/qt-3.3/lib/

ok,成功了,也進去了ptt.cc但是是亂碼,改了big5顯示後沒有回應,這是怎麼一回事?不知道,待解!

Print Friendly, PDF & Email

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料