libreadline5-dev

在Ununtu 7.10下自動安裝PostgreSQL會有錯誤?下

createuser -U postgres –createdb –adduser -P terp

這樣的命令會有什麼Insecure $ENV{PATH} while running setuid at /usr/bin/psql line 78.的錯誤,查看了Google沒有有效的解法,只找到一個建議叫我更新postgresql-common,哪找更新啊!有點裝笑ㄝ的感覺!

所以只好自己編譯了,第一次編譯時發生沒有readline library的錯誤,找了一會才知道在Ubuntu下這個套件名叫libreadline5-dev。

疑!一樣發生:

Insecure $ENV{PATH} while running setuid at /usr/bin/createuser line 78.
這樣的錯誤,看來不是系統錯,是我錯了,只好繼續看Postgresql的安裝文件:

『To do this, add the following to your shell start-up file, such as ~/.bash_profile (or /etc/profile, if you want it to affect every user):

PATH=/usr/local/pgsql/bin:$PATH

export PATH
』
我懷疑是環境變數沒設好的關係,加了這個果真OK!唉!太資淺了!
Print Friendly, PDF & Email

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料